Quantcast

Documentation Center

  • Trial Software
  • Product Updates

wvtool

Open Window Visualization Tool

Syntax

wvtool(WindowVector)
wvtool(WinObj)
wvtool(WindowVector1,WinObj1,...,WinObjN,WindowVectorN)
H = wvtool(...)

Description

wvtool(WindowVector) opens the Window Visualization Tool (WVTool) with time and frequency domain plots of the window vector specified in WindowVector. WindowVector must be a real-valued row or column vector. By default, the frequency domain plot is the magnitude squared of the Fourier transform of the window vector in decibels (dB). You can generate window vectors for a number of common window functions using the Signal Processing Toolbox™ software. See window for a list of supported window functions.

wvtool(WinObj) opens WVTool with time and frequency domain plots of the sigwin object WinObj. See sigwin for a list of supported signal processing window objects.

wvtool(WindowVector1,WinObj1,...,WinObjN,WindowVectorN) opens WVTool with time and frequency domain plots of the window vectors or window objects specified in WindowVector1,WinObj1,...,WinObjN, WindowVectorN.

H = wvtool(...) returns the figure handle H.

    Note   A related tool, wintool, is available for designing and analyzing windows.

    Note   If you launch WVTool from FDATool, an Add/Replace icon, which controls how new windows are added from FDATool, appears on the toolbar.

WVTool Menus

In addition to the usual menus items, wvtool contains these wvtool-specific menu commands:

File menu:

  • Export — Exports the displayed plot(s) to a graphic file.

Edit menu:

  • Copy figure — Copies the displayed plot(s) to the clipboard (available only on Windows platforms).

  • Copy options — Displays the Preferences dialog box (available only on Windows platforms).

  • Figure, Axes, and Current Object Properties — Displays the Property Editor.

View menu:

  • Time domain — Check to show the time domain plot.

  • Frequency domain — Check to show the frequency domain plot.

  • Legend — Toggles the window name legend on and off. This option is also available with the Legend toolbar button.

  • Analysis Parameters — Controls the response plot parameters, including number of points, range, x- and y-axis units, sampling frequency, and normalized magnitude.

    You can also access the Analysis Parameters by right-clicking the x-axis label of a plot in the Window Viewer panel.

  • Insert menu:

You use the Insert menu to add labels, titles, arrows, lines, text, and axes to your plots.

Tools menu:

  • Edit Plot — Turns on plot editing mode

  • Zoom In — Zooms in along both x- and y-axes.

  • Zoom X — Zooms in along the x-axis only. Drag the mouse in the x direction to select the zoom area.

  • Zoom Y — Zooms in along the y-axis only. Drag the mouse in the y direction to select the zoom area.

  • Full View — Returns to full view.

Examples

Compare Hamming, Hann, and Gaussian windows:

wvtool(hamming(64),hann(64),gausswin(64))
 

Compare Kaiser window objects with different beta values:

H = sigwin.kaiser(128,1.5);
% Kaiser window with beta=4.5
H1 = sigwin.kaiser(128,4.5);
wvtool(H,H1)

See Also

| | |

Was this topic helpful?